Re: [Maria-developers] 25fe7dbad5d: Reduce usage of strlen()

Hi, Michael! On Mar 31, Michael Widenius wrote:
I'll only mention actual mistakes, no style comments or suggestions or question, just want to get it over with.
belongs to a previous commit
This should be func_name().str, otherwise it'll crash or print garbage on Windows. Same below, in a couple of places.
return true; }
Regards, Sergei VP of MariaDB Server Engineering and security@mariadb.org

Hi! On Wed, Mar 31, 2021 at 5:18 PM Sergei Golubchik <serg@mariadb.org> wrote:
Sorry about that, must have happened when I did a fixup trying to keep things clean. How can I move most easily to the right commit. Do a rebase and do "edit" for the previous commit, do the change by hand and continue the rebase? Will try that.
Nope, this works thanks to this: inline const char *func_name() const { return (char*) func_name_cstring().str; } So func_name() can be used (instead of the old variable func_name) when one wants to have the a char* pointer. This was convenient to have for future merges and make the changes in the commit easier to read. Regards, Monty
participants (2)
-
Michael Widenius
-
Sergei Golubchik