Hi, Ian! On Jan 30, Ian Gilfillan wrote:
simultaneous_assignment would be my choice; as you say it's the most accurate, if a little long.
Thanks. That's what I'll end up with, I suppose. I preferred simultaneous_set, and even changed the code to use it, but then I realized that "set" is a data type - and let's not introduce an ambiguity, if we can avoid it. I considered simultaneous_assign, but it just didn't sound like English simultaneous_eval is too broad, expressions are evaluated everywhere all the time, so the name looks like it would affect a lot more cases than we want it to.
It's not only for update. There is a patch to fix SELECT ... INTO, and I suppose we'll have "simultaneous assignment" behavior everywhere eventually.
So, I'm leaning towards either simultaneous_assignment or simultaneous_set as mode names. The first is more exact, but it's rather long (sql_mode names range from 3 to 26 characters, and this one is 23). The second (with 16) fits right in the middle of the range, length-wise. But there's no SET keyword in SELECT ... INTO. On the other hand, there's no ASSIGNMENT keyword anywhere either :)
Regards, Sergei Chief Architect MariaDB and security@mariadb.org