Hi Sergei,

Weekly Report for 4th week of gsoc

1. Field property is_row_hash , field_visibility successfully saved and retrived from frm , using extra2 space
2. Some tests added.
3. Solved the error when there is another primary key(it used to accept duplicate in this case ).
4. Added hidden in parser.
5. Identified the memory leak 1 is because of malloc db_row_hash str.I did not freed it. second memory leak i am searching for it.
Work for this week.
1 First solve the memory leak problem.
3 in mysql_prepare_create_table I am using an iterator it would be better if i can add custom field when it says an error. So will not have to use iterator as suggested by you sir.
4 rename the hash field automatically in the case clash.
This week 
On Thu, Jun 16, 2016 at 11:46 PM, Sergei Golubchik <serg@mariadb.org> wrote:
Hi, Sachin!

On Jun 15, Sachin Setia wrote:
> But the major problem is:-
>  Consider this case
> create table tbl(abc int primary key,xyz blob unique);
> In this case , second key_info will have one user_defined_key_parts but two
> ext_key_parts
> second key_part refers to primary key.
> because of this ha_index_read_idx_map always return HA_ERR_KEY_NOT_FOUND
> I am trying to solve this problem.

I've seen you solved this, but I do not understand the problem (and so I
cannot understand the fix either).

Problem was 
consider this 
create table tbl(abc int primary key , xyz blob unique);
insert into tbl value(1,12);
insert into tbl value(2,12); # no error , details in commit comment https://github.com/MariaDB/server/commit/baecc73380084c61b9323a30f3e25977176e98b0
Please, try to add a test case for
the problem you're fixing. In the same commit, preferrably. 
Now you can still commit a test case for this problem and your fix,
then, I hope, I'll be able to understand better what the problem was.

Chief Architect MariaDB
and security@mariadb.org