On Thu, Apr 12, 2018 at 07:22:56PM +0200, Sergei Golubchik wrote:
Hi, Sergey!
On Apr 12, Sergey Petrunia wrote:
diff --git a/sql/item_strfunc.h b/sql/item_strfunc.h index 18cda491efd..49de5568696 100644 --- a/sql/item_strfunc.h +++ b/sql/item_strfunc.h @@ -1748,5 +1748,20 @@ class Item_func_dyncol_list: public Item_str_func { return get_item_copy<Item_func_dyncol_list>(thd, this); } };
-#endif /* ITEM_STRFUNC_INCLUDED */
Please add a note that this is not the "_rowid" that we support in the parser.
I used the terminology that you introduced, that is "keep_current_rowid".
But if you don't mind, I'd rather rename keep_current_rowid (and every "rowid" that I introduced) to keep_current_position (because it's handler::position()) or keep_current_ref (because it's handler::ref and handler::ref_length), whichever is less ambiguous.
I didn't want to request any renames actually. We use the term "rowid" in many places in the code. Until now, there has been no intersection with the SQL-level "_rowid". Now, with the new Item-derived class I was afraid there would be some confusion and wanted a comment to prevent it, that's all. BR Sergei -- Sergei Petrunia, Software Developer MariaDB Corporation | Skype: sergefp | Blog: http://s.petrunia.net/blog